Navisworks. Where Are The Civil Objects?


I know that this is a Civil 3D blog but I had to post this blog regarding Navisworks. In this case Civil 3D is involved though, so I guess that qualifies. So here is the deal. I recently did a Civil BIM model to show the infrastructure on a roadway project and all of the utilities and ground surfaces were created in Civil 3D. I brought the drawing into Navisworks and did not see any of the Civil objects. Right away I thought that it had to be a Civil Object Enabler issue which is the case, but there is one “small” catch; if you are using Navisworks 2010 64-bit version, there is not a 64-bit Civil Object Enabler available! What do you do in that case? Punt? No!

I decided to try something. As you can probably figure out, I am using a 64-bit machine so I am installing 64-bit apps on it. I decided to try to install 32-bit Navisworks along side the 64-bit version and apply the Civil Object Enabler to the 32-bit install. It worked! Once I installed the Civil Object Enabler to the 32-bit install I was able to see the Civil objects in Navisworks with no problem. The results are in the picture below. You can see the pipe network objects and the surface being displayed with a transparency. We can only hope that there will be a 64-bit version of the Civil Object Enabler at least for the 2011 version if one is not going to be made for the 2010 version.

navis-1

Civil Infrastructure software is my main professional interest. Civil 3D, Infraworks, and Recap are what I work with mostly. I have been with CADsoft Consulting for over 10 years now. I got my start using Softdesk and AutoCAD R12 in DOS. My wife and I have four children and I am a die hard Red Sox fan.